Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again

Hey @darragh.duffy, @miked,

Happy to hear you figured out the issue! :slight_smile:

Thanks for sharing your solution!

-Tommy

Hey @a7med.3bdelnasser22, @Evanatzend,

Please check the two possible solutions mentioned above by @miked and @darragh.duffy.

Let me know if that helps! :slight_smile:

Thanks,
Tommy

We too have the dreaded “Your connection timed out” error, but, on one specific machine…

We can succesfully start a meeting and have people join through web, on all other machines

Our specifics are:

  • We use SDK 1.7.8
  • Developer account is not pro
  • Developer API key/secret is not host account
  • Meeting starter account is not pro

(So all those things don’t seem to be causing it)

The machine that we can’t succesfully start a meeting with, has the latest zoom client installed, meeting-id and password are correct, no firewalls known, time is synced. Works client to client.

What are we missing?

1 Like

Hey @joep,

What type of machine, OS version, and browser?

Thanks,
Tommy

I am getting this below error msg from all browser.

Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again.

Hi Tommy,

Thank you for reaching out. I will get back to you with the specifics asap.

Best,

Joep

Hi Tommy,

This is what I know about the machine that we can’t connect to using the web SDK.

(As for the browser version: we use this machine to start a zoom meeting from the Zoom application, so there’s no browser involved)

image

Hey @tutorops24,

Please create a new topic if the solution did not work for you.

Thanks,
Tommy

Hey @joep,

Thanks for sharing the computer info. What browser are you using though?

The developer account who created the JWT App does need to be pro.

Thanks,
Tommy

Hi @tommy, thank you again for your response.

What browser are you using though?

Chrome, on Win10, both latest.

The developer account who created the JWT App does need to be pro

But that implies that it shouldn’t work at all, where in fact, it works everywhere except on the one single mac. How is that possible?

Best,

Joep

Hey @joep,

Thanks for the clarification! Can you make sure the Mac’s time settings are synced properly:

Thanks,
Tommy