Web SDK "joining fail"

Thanks for your information. Hope the zoom web back soon.

Happy to help, stay updated here:

Thanks,
Tommy

@tommy: can you help me over this, i am using real meeting id also.

1 Like

Hi @singhnikesh459,

Could you DM me your Account Number, Meeting ID, API Key/Secret?

Thanks

Hi

Michael_Purnell i am using jwt encryption please find other details except accountid below:

Api Key:

Api Secret :

Meeting ID :

4536120945

If you need any thing else kindly ask and help, i don’t know where to find account number because i am using jwt authentication.

Thanks,

Nikesh Sharma

@singhnikesh459,

Since this involves sensitive information, can you email us at developersupport@zoom.us?

Hi @Michael_Purnell,

i have emailed all asked details on developersupport@zoom.us,
please find details and help us to integrate.
mail sub: Connection Time Out On Meeting Join Issue BY singhnikesh459

Thanks @singhnikesh459,

We will be with you shortly.

-Tommy

any updates?
I’ve read the whole thread and using JWT key.
still getting same error (also tried all roles)

Thanks
Dekel

Hey @dekel.yaacov, you are using a real Zoom meeting id right?

Thanks,
Tommy

I’ve read the whole thread. Using the correct zoom id, jwt stuff(hardcoded) and its still not working.
Gives the error: ‘joining failed’

1 Like

Hey @dj.srivastava23,

Can you please share steps to reproduce the issue, your code, and the signature you are generating to developersupport@zoom.us so I can debug?

Thanks,
Tommy

Hi,

I’ve also read the whole thread and am experiencing the ‘Joining failed’ error code: 1 issue.

I was able to successfully initialize the Zoom meeting around the time 1.7.5 was released. Today neither 1.7.5 nor 1.7.6 works for me.

I get the signature and then initialize the Zoom WebSDK, then I try to join using the below code:

ZoomMtg.join({
      userEmail: 'user@xxx.com',
      meetingNumber: meetingJoinData.meetingNumber,
      userName: meetingJoinData.userName,
      signature: meetingJoinData.signature,
      passWord: meetingJoinData.passWord || '',
      apiKey: ZoomService.API_KEY,
      success: resolve,
      error: reject
    })

Hey @bruno,

Can you private message me the signature so I can debug?

Thanks,
Tommy

Hi,

Today it started working properly without any changes on our side, so it appears that this issue got solved.

Thanks!

Hi All,

We are implementing a fix for this bug, your issues should be resolved by tomorrow morning.

Hi All,

If you’re experiencing request timeout issues and have a Basic/Free account, the workaround would be to upgrade your account to a Pro account to resolve the issue.

Let us know if this works for you.

Thanks

Hi Guys. Just to let you know…

I was having these Joining Fail issues, and it was just because I was generating the signature incorrectly.
Being more specific, I was passing the “role” as a “0” (string) and not 0 (number).

I hope it helps someone!
Cheers

1 Like

Hey @gabrielsmelo.dev,

Thanks for sharing your solution! :slight_smile:

Have a great day!

-Tommy

@tommy please reply to this topic